The Stripe API is experiencing an outage
Incident Report for Chargehound
Resolved
This incident has been resolved.
Posted 8 days ago. Jul 10, 2019 - 17:11 UTC
Update
We are continuing to work on a fix for this issue.
Posted 8 days ago. Jul 10, 2019 - 16:56 UTC
Identified
The Stripe API is currently experience an outage and we are seeing increased error rates. They are aware of the issue.

https://twitter.com/stripestatus/status/1148997100673179648
Posted 8 days ago. Jul 10, 2019 - 16:56 UTC
This incident affected: Payment Processors.